Neste artigo veja boas práticas que devem ser adotadas ao gerar um arquivo .CSV para a integração/ manutenção.
1. Devem ser extraídos no formato .csv.
2. O delimitador entre colunas precisa ser o pipe - barra reta "|".
3. Se o nome do campo (que em uma planilha .csv seria o título da coluna) tiver mais de uma palavra, separar por underline. Também não utilize acentuação, cedilha e caracteres especiais no título da coluna.
• Exemplo: nome_fantasia
4. Em uma mesma coluna, utilizar um separador diferente do pipe caso tenha mais de um nome.
• Exemplo: se existir um campo 'Produtos' e nesse campo o cliente pode ter Chat, Bot, Email etc. Os produtos devem ser separados por vírgula sempre.
5. O separador decimal de campo do tipo número no csv é o ponto - “.” Se um campo do tipo número estiver utilizando vírgula, a leitura do arquivo vai tentar interpretar como texto e isso acaba resultando quebra. O arquivo não vai funcionar.
6. O arquivo precisa ser gerado no encoding UTF-8.
Para saber como fazer isso, siga os passos abaixo:
No EXCEL:
1. Após finalizar o preenchimento, clique na aba Arquivo, depois Salvar como;
2. Clique em Procurar para definir a pasta do computador em que o arquivo deverá ser salvo;
3. Digite o nome do arquivo;
4. No campo Tipo, procure e selecione CSV UTF 8 (Delimitado por vírgulas);
5. Então clique no botão Salvar.
No GOOGLE SHEETS:
1. Após finalizar o preenchimento, clique em Arquivo, depois em Fazer download;
2. Escolha Valores separados por vírgula (.csv, página atual) e, por padrão, o encoding será UTF-8;
3. Digite um nome e escolha a pasta do computador em que o arquivo deverá ser salvo;
4. Clique no botão Salvar.
Boas práticas que devem ser adotadas ao abrir um arquivo .CSV gerado pelo SenseData, no Excel
1. Abrir o EXCEL.
2. Clicar na aba de Dados;
3. Clicar em Obter Dados no canto superior esquerdo;
4. Selecionar a opção De arquivo;
5. Selecionar a opção Text/CSV;
6. Selecionar delimitador personalizado como o pipe - barra reta "|";
7. Clicar em Carregar e prontinho!
Boas práticas que devem ser adotadas ao abrir um arquivo .CSV gerado pelo SenseData, no Google Sheets
1. Abrir o GOOGLE SHEETS;
2. Clicar na aba Arquivo;
3. Clicar em Importar;
4. Fazer upload do arquivo em Fazer Upload;
5. Procurar pelo arquivo e selecioná-lo;
6. A tela de Importar Arquivo vai abrir e deve ser configurada da forma colocada no print abaixo;
7. Após isso, clicar em Importar Dados;
8. Depois disso, basta clicar em Abrir agora na mesma tela.
Pronto! Assim terá acesso ao documento com a melhor visualização.